Failed to obtain IP address from DHCP server

0 votes
Please would somebody with a bit more technical knowledge than the standard afrihost replies please assist me

I have been without FIbre since the 4th of August and despite numerous tickets logged and call backs requested my fibre is still not working

When I look at the WAN status in my DLINK router it says "Failed to Obtain IP address from DHCP server"

I hve rebooted and rest the CNT many times as well as the DLINK router

I have even plugged my laptop directly into the CNT

None of this helps

Trying to navigate to I am redirected to a DLINK page where is says checking internet connection where it eventually fails
asked Aug 15, 2018 in Fibre by MarkZA (180 points)
I to am having the same issue. I get nothing from Afrihost. Their DSL customer care was awesome, kept me happy for many years.

Have you found a solution that works?

Yes I finally got my Fibre working 2 weeks later

Dont let them tell you that the Line is fine. Get them to log a call with your Fibre Installer (in my case TT connect) to actually phone and manually check the ONT with you

Turns out mine was not configured correctly. So even though the line was fine it was not obtaining an IP address and thus not working

This is something they have to do remotely and involved using a paper clip to factory rest the device

Took about 30 -40 minutes but thankfully I have Fibre now
Can i just reset the fibre device myself or do they then have to do something

3 Answers

0 votes
Maybe ask them if you can get a staic ip on your connection.
answered Aug 17, 2018 by K1ngFallen (65,420 points)
0 votes

As we know that all devices on our home network are assigned a unique IP address by our DHCP server but if our ruark takes longer than usual to connect with network then it shows Failed to obtain IP address from DHCP server. If anyone getting this issue then i suggest you to take an advice from Toshiba Support for more help.

answered Oct 17, 2018 by NeilBhisma (500 points)
0 votes

In the first step to diagnosing go to the wireless adapter from a network location and click right, check your adapter setting and make sure TPCP/IP is set as dynamic and NOT static. but in some cases, we need to set static IP  if the router DHCP configuration is disabled. for more technical assistance you may take help of HughesNet Customer Service

answered Oct 18, 2018 by elenageorge (180 points)