Sending emails times out my application

0 votes

I have an asp.net core 2.1 app that times out when I try to send an email. The application is hosted on Azure. I am using port 465 becuase using port 578 gave me a "TLS currently unavailable" error and I've read that this error usually occurs becuase of SSL.

  • Currently using: mail.(my domain).co.za and port 465 - Resulting in a timeout.
  • Previously tried: smtp.afrihot.co.za and port 587 - Resulting in a "TLS currently unavailable" error.
  • Previously tried: smtp.afrihot.co.za and port 465 - Resulting in a "No connection could be made because the target machine actively refused it 169.1.1.77:465" error.

Am I missing something? Maybe I'm using the wrong combination?

Any help will be appreciated,

Kind regards

asked Apr 19 in Email Hosting by Isidore (160 points)
edited Apr 19 by Isidore

1 Answer

0 votes
I did some trial and error, I guess I should've tried more before posting but maybe this can be useful to someone else. I used port 587 and SMTP client mail.(domain name).co.za eg, mail.mywebsite.co.za.
answered Apr 19 by Isidore (160 points)
...