Uploading images to a Wordpress installation returning an http error?

+2 votes
Please help!

Every time i try and upload an image to my wordpress website, it fails with the error "http error"
asked Apr 22, 2015 in Shared Hosting by anonymous

1 Answer

0 votes
When creating or editing a WordPress page or blog post, you can easily add images at any time using the WordPress Media Uploader tool. Here’s how to add an image, step-by-step, using the media uploader:

Step 1 – Placing your cursor - In order to add an image to your page or post, you must first insert your cursor in the place in the text where you want the image to appear. By placing your cursor within your text, you can add images inline with your content. You can also place your cursor on a blank line if you want the image to appear by itself instead.

Step 2 – Click the Add Media button - Once you’ve placed your cursor on the line where you want your image to appear, click on the Add Media button to launch the media uploader interface, and then select the Insert Media option from the list of actions in the left side of the media uploader window.

Step 3 – Add or Select Your Image - You can add or select the image you want to add to your page or post by choosing from either of the following options in the center of the media uploader window:

    Upload Files: Upload the image you want to use from your computer by dragging it into the upload area.
    Media Library: Select from any previously uploaded images in the media library by clicking on the one you wish to add to your page or post.

Once you have selected or uploaded the image you want to add, You will see a checkbox next to the thumbnail confirming your selection, and see information about it displayed in the Attachment Details pane on the right hand side of the media uploader interface.
answered Apr 22, 2015 by AfriDude (43,950 points)
Thanks AfriDude. This is however a “how to upload” answer. I’m however having exactly the same problem. I did exactly what you explained above, just to find Wordpress giving me a “HTTP error”. The file is small (60kb), so not a size issue. I’ve uninstalled Wordpress and reinstalled it again, but still not joy. I’ve login in via Explorer, Chrome and Safari, with all three giving me the same error. Just for interest sake, I uninstalled Wordpress and installed Joomla. When I tried uploading a picture/file with Joomla it also gave me an error, stating that I don’t have permission to upload a file to the destination. I’m not technical enough to make a call, but do feel that the problem must be with my hosting (Afrihost)?
...