Problems installing Wordpress

+7 votes
Hi, I am wanting to download Wordpress to my domain so I can edit and design my webpage but it keeps saying, "The maximum number of databases you can create has been reached, so installation cannot proceed." I ordered the Silver Home Linux Hosting and I am just getting started (haven't done anything to my domain yet!). Can I unistall something else to allow me to install wordpress or is this only available through some type of upgrade?  If I can't use Wordpress I'm going to have to cancel my account unfortunately!
asked Jan 21, 2015 in Shared Hosting by anonymous
edited Jan 22, 2015 by AfriGenie
Hi, I've now upgraded to the Gold Home Package and waited about 20 hours. I am trying to install wordpress following the exact directions you gave (I have made sure there are no databases already associated with the account under "My SQL databases" and have tried to start from scratch to download wordpress). It is still telling me "The maximum number of databases you can create has been reached, so installation cannot proceed." Why is it not working? Thanks.

2 Answers

0 votes
Hi there

First you need to make sure that you are on a Gold Home package or higher. WordPress and requires a database, the first package that comes with a database is a Gold Home package. If you already on a package that allows a database, to resolve this issue you need to uninstall WordPress and login to cPanel to delete the databases that are stored there. In cPanel, scroll down to Databases, select MySQL Databases. You need to delete the database and users to start from scratch. Once you have deleted the databases and uninstalled Wordpress you should try running the installation again. If you are installing the latest version of Wordpress, I would suggest that you do it through cPanel. To install WordPress through cPanel, on the main cPanel screen, scroll all the way down to Softaculous Apps Installer. Once you are in Softaculous you will see WordPress and other CMS's. Click on WordPress and install it from there. Everything else will be created for you! The installation is also quick, it literally takes a few seconds, and you will be able to login the back-end of WordPress to start building your site.

Afrihost Team
answered Jan 21, 2015 by AfriDude (43,930 points)
Thank you!! One more quick question: earlier today I could log into my C-panel just fine by logging into my account going to hosting, clicking on my domain, and then clicking c-panel and login. However, now whenever I try to sign in it opens a link saying bad gateway and recommending I contact support since the auto direct might be broken. Could you tell me what I can do to get back into c-panel. Thanks again for all the clear instructions and help thus far!
Email me your domain name on answers@afrihost.com so that i can check what the problem is.
Thanks I actually managed to sort it out. Not sure why it was glitching. Now that I am back in and have upgraded to Gold Home and double checked that there are no databases listed under my SQL Databases I am trying to install wordpress again and it is saying the same thing, that "The maximum number of databases you can create has been reached, so installation cannot proceed." Is there a chance it will take 24 hours for it to register my upgrade to the Gold Home package?
How do I install Wordpress?
Hi There

I have installed wordpress through Softaculous but can't log into the backend of the website. No log in details work. PLEASE HELP!!!!
Same problem with the SEO panel.
I've even tried reinstalling each.
thank you sir...
Hi,

Sorry, you mentioned that you need to upgrade to the Gold Home if you're using Linux but on afrihost's website you guys say that the Silver Home comes with 1x MySQL Database already. So why can't i have access to it?
0 votes
I get the feeling that you are creating a new database everytime you are trying to install.

 

Truncate current tables in PHPMYAdmin
answered Jan 23, 2015 by Matthew Murdoch (64,690 points)
Not the case, I too have a similar problem. I'm a new user and already I can't install WordPress.. I have no databases created either then the default Information Schema on the PhPAdmin.. Please solve this issue for us asap, otherwise we will have no other choice but to terminate our acounts with AfriHost.
hi guys this is also what im expierience im also new to wordpress and seemingly we just cant get it right or can afrihost assist in this matter hope they reply asap
For future support seekers-
The issue was fixed after I entered the Database Wizard and started creating a new database (no need to create a new user, just press next, then go back). When I went back to MySQL Databases the new database appeared there, and I was able to delete it. The message about exceeding the maximum number of databases was gone!
...