After porting my caller ID is not showing up on other people's phones. How do I fix this ?

+2 votes
asked Feb 10, 2016 in Voice by anonymous

1 Answer

+1 vote
Fortunately the fix is pretty simple.
 
You can set your caller ID to ON or OFF under your phone settings.
 
When set to ON, your caller ID will show and when set to OFF, your caller ID will not show.
 So when you see that your caller ID is not showing when making outgoing calls then it is safe to assume that it is set to OFF.
Below are steps you need to follow on iOS and Android in order to enable your caller ID.
 
iOS (version 9+): Select Settings >> Phone >> Show My Caller ID (Activate here)
 
Android (5.0.1 Samsung S4): Select Settings >> My Device >> Call >> More settings >> Caller ID >> Show Number
 
Since there are quite a large number of android phones in the market it might differ from device brand to device  brand but basically you find the setting under phone settings.
answered Feb 10, 2016 by Simphiwe
edited Feb 10, 2016
...