Why does my router's webpage (192.168.1.1) take as long to load / browse as an international website?

+2 votes
I've used multiple brands of routers over the years, and almost every one of them takes ages to display the interface page, and clicking on settings and browsing around has similar delays that you normally experience from international sites.

This makes no sense to me as the data on the page is on my local network, and it's almost all text. What's going on?
asked Jan 29, 2015 in Devices by prodigyX (600 points)
10.0.0.2 might work

2 Answers

+1 vote
 
Best answer
The web page is being served up by the router, not a web server, and it's not static data. So every time you log in or change a 'page', the router has to fetch the information from its firmware and populate the page with the information requested. The time taken is not so much to send the page to you as it is to check all its fingers and toes so that the correct data is shown. Sometimes firmware upgrades improve matters, but not necessarily.
answered Mar 18, 2015 by j0nn0
selected Mar 19, 2015 by prodigyX
+1 vote
That's definitely a pretty strange symptom. It may be a sign that the method you're using to connect to the router has problems. Try connecting only via LAN cable, with WiFi switched off, and also try swopping out the LAN cable in case there is an intermittent break in the cable.

You should also be able to see if there is latency to your router from a traceroute, and you can measure any packet loss by pinging the router.

A good place to start would be to check the firewall settings on your PC, and then disable firewall and anti-virus completely. If your AV is set to a strcit setting it could be scanning every outgoing packet and slowing down your traffic.

If you've used different routers, try isolating whatever is common - the PC, cabling or any network devices like switches that you may have continued to use.
answered Jan 29, 2015 by AfriMan (14,640 points)
...